Función SI de Excel

Función SI de Excel

¿Qué es?

La función SI en Excel forma parte de las funciones lógicas, es indispensable al evaluar condicionales, para determinar si es falsa o verdadera. Es de gran ayuda para tomar acciones en base a un resultado obtenido en una prueba lógica. Es decir, te permite realizar comparaciones lógicas entre un valor y un resultado que espera. Además permite combinarla con muchas funciones más, incluso siendo argumento de las mismas.

Sintaxis

=SI(prueba_logica; valor_si_verdadero; valor _si_falso)

  • prueba_lógicaObligatoria. Puede ser desde una fórmula lógica matemática, como B1>2 o A3=0, una comparación con un texto o una cadena alfanumérica, como C3<>”SI” o bién D5=”CONSTITUCION” hasta una fórmula de cadenas de Excel. Si se cumple la prueba lógica, se considera verdadera y la función asigna el valor_si_verdadero. En caso de que sea falsa se asigna el valor_si_falso.
  • valor_si_verdaderoOpcional. Es el valor que asignará la función SI en el caso de que la prueba lógica sea verdadera. Puede ser un valor numérico como 7, una cadena como “Verdadero” o incluso otra fórmula de Excel. En el caso de omitir esta variable, dejando la función como =SI(B2<5;;”Falso”), su valor será 0 por defecto.
  • valor_si_falsoOpcional. Se le asignará este valor a la función si de Excel la prueba_lógica da falso. Al igual que el valor_si_verdadero, puede tomar cualquier tipo de valor o fórmula. Si se omite este valor en la sintaxis, como por ejemplo =SI(B2=”Ramón”;3;), se le asignará por defecto el valor 0.

Importante: en la casilla prueba_lógica, si el valor a comparar es numérico, se escribe ese valor sin más B2=5, pero si es un texto o una cadena alfanumérica, obligatoriamente debe estar encerrada entre comillas H2=”PASA” o en alfanumerico A6=”AUDI3″.

Las comparaciones son = equivale a igual que, > mayor que, < menor que, >= mayor o igual que, <= menor o igual que y <> diferente a

En términos mas sencillos podemos decir que; Lo que escribamos dentro del segundo y tercer argumento serán las acciones que se realizarán en caso de que la respuesta a la pregunta lógica sea verdadera o sea falsa. Los dos primeros argumentos son los únicos obligatorios para esta función.

Para realizar la pregunta lógica podremos utilizar los siguientes operadores de comparación:

= para preguntar si dos valores son iguales

> para saber si un valor es mayor que otro

< para preguntar por menor

>= con este podremos conocer si es mayor o igual

<= preguntamos por menor o igual

<> si deseamos mirar sin son diferente utilizaremos

Ejemplo

En este ejemplo queremos saber si la celda B4 es mayor que la celda B5. Para ello escribimos la función que podemos ver a continuación, en la celda que deseamos adquirir el resultado de la operacion.

=SI(B4>B5;VERDADERO;FALSO)

Ten en cuenta que en la función SI o en cualquier función en Excel no hace falta que escribas VERDADERO o FALSO entre comillas puesto que son variables preparadas por Excel.

En cambio, si quieres poner otros valores de texto sí que deberás escribir las soluciones entre comillas:

=SI(B5>B4;"Es mayor";"No es mayor")

El resultado de la función SI en Excel en este caso es VERDADERO.

Deja un comentario